Search found 8 matches

by Chrisoduro09
Mon Feb 24, 2020 5:48 pm
Forum: The Garage - Technical Forum
Topic: speedo/abs
Replies: 11
Views: 1388

Re: speedo/abs

kit sent you pm with details . no reply ???
by Chrisoduro09
Thu Feb 20, 2020 6:42 pm
Forum: The Garage - Technical Forum
Topic: Can i simply replace my ABS Control Module ?
Replies: 13
Views: 1506

Re: Can i simply replace my ABS Control Module ?

Well done joe .where was your broken wire and does that mean the trouble with your old module was down to the broken wire ? your old module is still good then , happy days.
by Chrisoduro09
Mon Feb 17, 2020 8:34 pm
Forum: The Garage - Technical Forum
Topic: Can i simply replace my ABS Control Module ?
Replies: 13
Views: 1506

Re: Can i simply replace my ABS Control Module ?

You are not alone I am having same problem . If you get any good news let me know , thanks.
by Chrisoduro09
Mon Feb 17, 2020 8:16 pm
Forum: The Garage - Technical Forum
Topic: speedo/abs
Replies: 11
Views: 1388

Re: speedo/abs

The abs module I need is a KB44 67650 if any one knows where there is one let me know thanks.
by Chrisoduro09
Mon Feb 17, 2020 7:49 pm
Forum: The Garage - Technical Forum
Topic: speedo/abs
Replies: 11
Views: 1388

Re: speedo/abs

Do you reckon a module from a 95 car might work ? cheers
by Chrisoduro09
Mon Feb 17, 2020 6:44 pm
Forum: The Garage - Technical Forum
Topic: speedo/abs
Replies: 11
Views: 1388

Re: speedo/abs

Finally got codes out of abs but not good news . I have a 12 left front sensor 13 right rear sensor 14 left rear sensor and worst a 61 abs control module !! . so as per my first post I have replaced the 2 rear sensors . probe front sensor seems hard to find ,will mazda 626 sensor work as there are p...
by Chrisoduro09
Wed Feb 12, 2020 9:38 pm
Forum: The Garage - Technical Forum
Topic: speedo/abs
Replies: 11
Views: 1388

Re: speedo/abs

Have tried several times with jumper wire and meter as per manual and got nothing. thanks
by Chrisoduro09
Wed Feb 12, 2020 6:51 pm
Forum: The Garage - Technical Forum
Topic: speedo/abs
Replies: 11
Views: 1388

speedo/abs

new to probe forum so hello. I have my 94 pro 2.0 6 months now but also have 2 problems and not sure if there linked . First is speedo stopped working recently and 2nd abs light comes on at 20mph but it done this from start . I have replaced the 2 rear abs sensors , is the abs module the problem ?.