Abs code reading reports all 4 sensors!?

For all technical questions. VIEWABLE without login, you need to register (free) to be able to post a question.
Post Reply
MikeyG
Full Member
Posts: 26
Joined: Thu Nov 29, 2018 6:01 pm

Abs code reading reports all 4 sensors!?

Post by MikeyG » Tue Jun 11, 2019 12:27 am

Hey,

I'm having problems pulling codes from the diagnostics box. I was using a paperclip to connect GND and TBS, then turning the ignition 2 turns. After trying it maybe 20 times the error codes were only shown twice. (They would go through the codes once, then the abs light would stay solid on.)

The codes were: 11, 12, 13, 14, then either 51 or 61.

I've checked and cleaned all 4 sensors (all have good resistance) so I'm guessing it's somewhere else. The cars had the abs light on for the past 6 years, and there's slight damage to the rear panels where I'm guessing they've checked the sensors too. So it's probably something more serious. Any help would be greatly appreciated.

Thanks,

mojo98
Area Rep
Posts: 754
Joined: Thu Sep 06, 2018 10:52 pm
Has thanked: 2 times
Been thanked: 2 times

Re: Abs code reading reports all 4 sensors!?

Post by mojo98 » Tue Jun 11, 2019 7:13 am

I would change the ABS control unit, its behind the passenger side rear panel, (where the rear speaker is)

MikeyG
Full Member
Posts: 26
Joined: Thu Nov 29, 2018 6:01 pm

Re: Abs code reading reports all 4 sensors!?

Post by MikeyG » Tue Jun 11, 2019 9:03 pm

Hey, I took the panel off and couldn't find it. Could you post a photo?

When the diagnostics are flashing out the codes, it works for about 15 seconds, then there is a click and the abs light stays on permanently. Could this be a relay problem?

2l 1995 btw.

Thanks.

MikeyG
Full Member
Posts: 26
Joined: Thu Nov 29, 2018 6:01 pm

Re: Abs code reading reports all 4 sensors!?

Post by MikeyG » Fri Jun 14, 2019 8:50 pm

This is driving me nuts. If anyone can point me to the 1995 2l ABS control module I'll be forever in your debt.

mojo98
Area Rep
Posts: 754
Joined: Thu Sep 06, 2018 10:52 pm
Has thanked: 2 times
Been thanked: 2 times

Re: Abs code reading reports all 4 sensors!?

Post by mojo98 » Fri Jun 14, 2019 9:00 pm

Its was the passenger side panel you removed, (rear speaker panel) once off, you will need to take a piece of plastic off the body and you should see the ABS control unit plus attached to it is the remote door lock unit,
I haven't got a picture and wont have a pic for a couple of weeks with a double check one on one of mine.

MikeyG
Full Member
Posts: 26
Joined: Thu Nov 29, 2018 6:01 pm

Re: Abs code reading reports all 4 sensors!?

Post by MikeyG » Fri Jun 14, 2019 9:03 pm

Behind this panel?


Image

Think I'm going a little loopy.

mojo98
Area Rep
Posts: 754
Joined: Thu Sep 06, 2018 10:52 pm
Has thanked: 2 times
Been thanked: 2 times

Re: Abs code reading reports all 4 sensors!?

Post by mojo98 » Fri Jun 14, 2019 9:06 pm

MikeyG wrote:
Fri Jun 14, 2019 9:03 pm
Behind this panel?


Image

Think I'm going a little loopy.
Yes that panel, then removed some rubber soundproofing then its behind that :D

cpt black
Tech Rep
Posts: 430
Joined: Fri Sep 07, 2018 8:28 am
Been thanked: 8 times

Re: Abs code reading reports all 4 sensors!?

Post by cpt black » Fri Jun 14, 2019 9:09 pm

Yes behind that panel,it will be there by the speaker metal box and a black plastic
unit attached ;)

MikeyG
Full Member
Posts: 26
Joined: Thu Nov 29, 2018 6:01 pm

Re: Abs code reading reports all 4 sensors!?

Post by MikeyG » Fri Jun 14, 2019 9:55 pm

Got it, mojo I never should have doubted you, your both legends (I would have taken the whole dash apart.)

Is the black box the failsafe relay?

Thanks again guys, absolutely over the moon!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest