speedo/abs

For all technical questions. VIEWABLE without login, you need to register (free) to be able to post a question.
Chrisoduro09
Registered User
Posts: 8
Joined: Tue Feb 11, 2020 5:52 pm
Been thanked: 1 time

speedo/abs

Post by Chrisoduro09 » Wed Feb 12, 2020 6:51 pm

new to probe forum so hello. I have my 94 pro 2.0 6 months now but also have 2 problems and not sure if there linked . First is speedo stopped working recently and 2nd abs light comes on at 20mph but it done this from start . I have replaced the 2 rear abs sensors , is the abs module the problem ?.

mojo98
Area Rep
Posts: 1090
Joined: Thu Sep 06, 2018 10:52 pm
Has thanked: 3 times
Been thanked: 7 times

Re: speedo/abs

Post by mojo98 » Wed Feb 12, 2020 7:27 pm

Chrisoduro09 wrote:
Wed Feb 12, 2020 6:51 pm
new to probe forum so hello. I have my 94 pro 2.0 6 months now but also have 2 problems and not sure if there linked . First is speedo stopped working recently and 2nd abs light comes on at 20mph but it done this from start . I have replaced the 2 rear abs sensors , is the abs module the problem ?.
Have you pulled the abs codes,

Chrisoduro09
Registered User
Posts: 8
Joined: Tue Feb 11, 2020 5:52 pm
Been thanked: 1 time

Re: speedo/abs

Post by Chrisoduro09 » Wed Feb 12, 2020 9:38 pm

Have tried several times with jumper wire and meter as per manual and got nothing. thanks

Sunfly
Full Member
Posts: 406
Joined: Fri Sep 07, 2018 9:11 am
Been thanked: 2 times

Re: speedo/abs

Post by Sunfly » Thu Feb 13, 2020 8:12 am

I wouldn't like to say there is a relation between these two apparently unconnected faults, however...!

When my 94 16v was say 10years old (I bought it new) and had done over 200k miles it had an odd fault on the rare occasion I exceeded 100mph, and it was pretty precisely 100mph. A light would come on at that speed and stay on thereafter, until I switched the engine off. That would reset it. It was a long time ago, but I'm pretty certain it was the ABS light. Unfortunately I never found the cause and was probably electronic because the car was well maintained and went through at least 4 MOT's with that fault (not identified or apparent to the examiner). I never had a loss of speedo fault otherwise I would have wanted to try to get to the bottom of it.

100mph you can live with but 20mph and no speedo is a bit of a bummer.

Start with mojo's advice for which you will need a diode.

Micron
Site Admin
Posts: 713
Joined: Thu Sep 06, 2018 6:08 pm
Been thanked: 3 times

Re: speedo/abs

Post by Micron » Thu Feb 13, 2020 10:23 am

Chrisoduro09 wrote:
Wed Feb 12, 2020 9:38 pm
Have tried several times with jumper wire and meter as per manual and got nothing. thanks
As mentioned, you need a diode, NOT a meter,

Chrisoduro09
Registered User
Posts: 8
Joined: Tue Feb 11, 2020 5:52 pm
Been thanked: 1 time

Re: speedo/abs

Post by Chrisoduro09 » Mon Feb 17, 2020 6:44 pm

Finally got codes out of abs but not good news . I have a 12 left front sensor 13 right rear sensor 14 left rear sensor and worst a 61 abs control module !! . so as per my first post I have replaced the 2 rear sensors . probe front sensor seems hard to find ,will mazda 626 sensor work as there are plenty of them and cheap and does the module have to be 94 or would a 95 do . thanks again for tips and info.

Micron
Site Admin
Posts: 713
Joined: Thu Sep 06, 2018 6:08 pm
Been thanked: 3 times

Re: speedo/abs

Post by Micron » Mon Feb 17, 2020 6:49 pm

The control module fault could be flagging up other issues, I would change that first.

Chrisoduro09
Registered User
Posts: 8
Joined: Tue Feb 11, 2020 5:52 pm
Been thanked: 1 time

Re: speedo/abs

Post by Chrisoduro09 » Mon Feb 17, 2020 7:49 pm

Do you reckon a module from a 95 car might work ? cheers

Chrisoduro09
Registered User
Posts: 8
Joined: Tue Feb 11, 2020 5:52 pm
Been thanked: 1 time

Re: speedo/abs

Post by Chrisoduro09 » Mon Feb 17, 2020 8:16 pm

The abs module I need is a KB44 67650 if any one knows where there is one let me know thanks.

Kit
Tech Rep
Posts: 769
Joined: Fri Sep 07, 2018 8:16 pm
Has thanked: 10 times
Been thanked: 12 times

Re: speedo/abs

Post by Kit » Tue Feb 18, 2020 5:39 pm

Chrisoduro09 wrote:
Mon Feb 17, 2020 8:16 pm
The abs module I need is a KB44 67650 if any one knows where there is one let me know thanks.
Got another one here, same ‘special Forum Member’ price as, the last one I sold to Joe

£30 posted,

If you’re interested, drop me a PM with your address

Send some Funds to my Pay-pal & I’ll get it in the post

Kit

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests